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IBM Lotus Notes 7.0.1 for Linux Release Notes 

About this release


Welcome to IBM Lotus Notes for Linux 
Welcome to the IBM® Lotus® Notes® for Linux software product.  This is the first release of Lotus Notes 
for Linux, bringing the world's leading products for information management, messaging, and 
collaboration to the Linux platform. The Notes 7.0.1 release provides the rich functionality of the Notes 
client to the Linux platform, using the Workplace Managed Client platform to host these capabilities.  For 
an overview of the features in this release, see the "About this release" chapter of these release notes. 

Before installing, please review the "Installation, migration, upgrade, and configuration information" 
chapter of these Release Notes. 

To ensure that you have the very latest version of the Notes and Domino Release Notes, please visit the 
Lotus Documentation page at: 

http://www.lotus.com/ldd/doc 

Using Notes for Linux 
Notes for Linux operates in a way similar to the Notes Client on Windows, but is hosted with the 
Workplace Managed Client platform.  The Notes applications may be accessed through the Notes 
Application navigator or from the Workspace. 

Once the Notes Application is active, the menus available to the Notes Client will also be available from 
within the Managed Client while the tabbed pages are showing Notes content. 
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Installation, migration, upgrade, and configuration 
information 

Software requirements 

System requirements 
This release of the Notes client on Linux requires a Workplace Managed Client platform image which is 
supplied to host Notes as a plug-in. The forthcoming release of the Workplace Managed Client will also 
be able to host Notes as a plug-in, in a similar manner to the Windows Notes application plug-in. To use 
Notes for Linux, the following requirements must be met: 

RedHat Linux Release  4, Update 3 

z Installation of the WMC platform and Notes Application Plug-in on the same machine 

z RedHat Linux Release 4, Update 3 

z Gnome Desktop version 2.8.0-5 

z Window Manager Metacity 2.8.6-2.8 

z Notes Domino Server running 6.5.4 or higher 

z Mozilla 1.7.12 

z Minimum System Memory -  512 MB (recommended 1 GB) 

z Disk space - 2 GB on the partitions where the product is installed to 

SUSE Linux Enterprise Desktop  (SLED) 10 

z Installation of the WMC platform and Notes Application Plug-in on the same machine 

z SUSE Linux Enterprise Desktop (SLED) 10 

z Gnome Desktop version 2.12.2-25.2 

z Notes Domino Server running 6.5.4 or higher 

z Mozilla 1.7.12 - gtk 

z Minimum System Memory -  512 MB (recommended 1 GB) 

z Disk space - 2 GB on the partitions where the product is installed to 

z Required RPM files for SLED 10. 

- FileName: compiz-cvs_060616-1.17.i586.rpm 

- FileName: metacity-2.12.2-29.i586.rpm 

- FileName: xgl-cvs_060522-0.13.i586.rpm 

These RPM files are located in the Notes_linux_sled10_patch_Oct16.zip file.  You can 
download this patch from the following website: 

ftp://ftp.software.ibm.com/software/lotus/fixes/notes/Notes_linux_sled10_patch_Oct16.zip 
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Run the following commands:

 #su - root

 #cd /tmp

 #unzip Notes_linux_sled10_patch_Oct16.zip

 #cd /tmp/sled10/

 #rpm -Uvh compiz-cvs_060616-1.17.i586.rpm

  #rpm -Uvh metacity-2.12.2-29.i586.rpm

 #rpm -Uvh xgl-cvs_060522-0.13.i586.rpm 

Note: Metacity, XGL, and Compiz files can also be downloaded from the Novell update site. To get 
updates from the Novell site, you must register your desktop. 

Installation notes 

Installation instructions for Notes for Linux

In order to be able to use Notes for Linux it is necessary to install the framework of IBM's Workplace

Managed Client. These components are supplied as part of Notes for Linux, but as a separate image.  

The following sections provide details of the components supplied, and how to use them to install Notes

for Linux.


z personality.zip 

This .zip file contains the installation framework for IBM's Workplace Managed Client.  It contains all 
the necessary components to install the framework, as well as the Notes installation package. This file 
may be unzipped to either a local drive or to a Linux file server. It contains an updateSite directory that 
contains all the Workplace features and plug-ins needed by Notes.  It also contains a deploy directory 
that controls the provisioning of the features in the updateSite. 

z setuplinux.bin 

This file contains the Notes components to enable Notes for Linux.  It is a self-contained installation 
file, but is recommended to be installed using the deploy directory provided within 
personality.zip. To do this, refer to the instructions below to place the file in the appropriate 
directory. 
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Installation steps 

1.	 Login as a non-root user. 

2.	 Unzip the file personality.zip as non-root user into a directory such as "plugin" in a user's home 
directory or other working directory.  This could be a network-mounted directory if you want many 
machines to be able to install from one updateSite. 

#unzip Personality .zip –d plugin 

3.	 Place the setuplinux.bin file in the correct directory, removing any existing one. 

#cd 
plugin/updateSite/features//com.ibm.workplace.notesinstall.linux.feature_7.0.1.0000-0900/bin/linux/ 

#rm setuplinux.bin 

Copy the new setuplinux.bin file inside the above directory. 

4.	 Choose the location for the Workplace Components 

The default location for these components is /opt/IBM. To use this location, ensure the permissions 
are set to 777 for the "IBM" directory.  If this is not desired, please choose a location that is writeable, 
such as within the user's home directory. 

5.	 Before installing verify that Mozilla has been registered with the GRE registration, to do this: 

#cd /etc/gre.d

#cat /etc/gre.conf


The content should include an entry similar to this:


[1.7.12]

GRE_PATH=/usr/lib/mozilla-1.7.12.lwp


If this does not exist refer to troubleshooting section for details on how to download the appropriate 
Mozilla version and configure this file 

6.	 Start the installation process, first ensuring that the setup_wct_platform.bin has execute 
permissions, by using the chmod command. 

#cd plugin 

#chmod 777 setup_wct_platform.bin


#./ setup_wct_platform.bin
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7.	 The Notes Installation process: 

- Select Next on the Welcome screen 

- The Software License window comes up, Select "I accept both the IBM and the non -IBM terms". 

- The Installation window with the Workplace Managed Client directory comes up; make sure to 
choose a location that the user has write permission to. 

- Choose the defaults and Click Next, or choose another writeable directory and Click Next 

- Click Next to start the installation on the window confirming that the Lotus Notes Plug-in will be 
installed. 

- Once the installation is done, a window appears saying that the files have successfully installed. 
Click Next to start the Workplace Managed Client setup. 

- You will then see the provisioning system provision the features and plug-ins needed for Notes. 

- When it provisions the feature containing the Notes installer, you will be presented with the license 
agreement for Notes. Select "I accept the terms of the license agreement " and Click Next. 

- Once you click Next, the Notes Plug-in starts installing. 

- Once the installer is finished, the wizard will require you to logout and log back in to get the Notes 
environment variables set. 

- Click Finish, and click Finish again. 

- Log out from the User session and log back in as the user you just installed Notes under. 

8.	 SUSE Linux Enterprise Desktop  (SLED) 10 only 

- Apply the software patch Notes_linux_sled10_patch_Oct16.zip, provided by IBM. See 
"System requirements" in these release notes for information about downloading this patch from the 
IBM Support website, and applying it to your system. 

FileName:  patch701_Oct16 
Location: ftp://ftp.software.ibm.com/software/lotus/fixes/notes/Notes_linux_sled10_patch_Oct16.zip 

- Copy the patch zip file to /tmp directory and Apply Patch as non-root user:


#cd /tmp


#unzip Notes_linux_sled10_patch_Oct16.zip


#cd /home/<username>/notes


#patch -p1 < /tmp/sled10/patch701_Oct16


9.	 Once you have applied the patch, when you log back in you should have an IBM Lotus Notes icon on 
your desktop; double-click the icon.  The Notes personality of the Workplace Managed Client will start 
using the Notes for Linux plug-in.  Notes setup will start, with dialogs asking for your Notes user 
information.  Once you configure Notes with the appropriate information, you are able to use Notes for 
Linux. 
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Server provisioned installation of Notes for Linux 
To use Notes as a plug-in for Linux requires the use of a Workplace 2.6.1 server.  The following directions 
for setting up the server to correctly provision the Notes plug-in for Linux to the user's machine assumes 
the Workplace server is version 2.6.1 or later. 

By default, when a Workplace Managed Client  Server Client Install (SCI) package is installed on a 
Workplace Collaborations Services server, the ability for a user to provision the Notes Application 
Plug-ins from the server is restricted to Windows client machines.  The following describes how to modify 
the Workplace Server environment to enable users to provision the Notes client from a Linux client: 

1. Setup the Workplace Server following the usual procedure(s). 

2. Create a text file called install.properties that contains the following lines: 

install.enable=true 
install.exec.command.linux=bin/linux/setuplinux.bin -W 

welcome.active=False -W destination.active=False -W datadir.active=False 
-W preview.active=False -W summary.active=False -W bean6.active=False -W 
bean7.active=False -W bean10.active=False


install.binary.linux=bin/linux/setuplinux.bin


and copy it to the following HTTP Server directory: 

<drive>:\IBMHttpServer\ 
htdocs\en_US\lwpupdate\wct\features\com.ibm.workplace.notesinstall.linux.feature_<version####> 

Note: The default install.properties file (located in the above directory) has only 
install.enable=false in it.  It can be renamed, or deleted and replaced with the text file you 
create above.  The following describes the changes to this file: 

install.exec.command.linux - defines what the command line statement is to execute the 
installer 
install.binary.linux - defines the name of the executable (full path) 
install.enable - set to "true" or "false" that determines whether the install is executed 

3. Copy setuplinux.bin for the desired build to the following HTTP Server directory: 

<drive>:\IBMHttpServer\ 
htdocs\en_US\lwpupdate\wct\features\com.ibm.workplace.notesinstall.linux.feature_<version####>\ 
bin\linux 

Note: Delete or rename existing setuplinux.bin that resides in this folder if there is one.  Ask your 
administrator where to find setuplinux.bin for the desired build. 

4. Since setuplinux.bin is a large file, please consider possible network impact in how initial 
deployment is made within an organization. 
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"Cannot validate Mozilla version " error on install 
When installing Notes for Linux to a Linux workstation, the error "Cannot validate Mozilla version" 
indicates that version 1.7 of Mozilla with GTK2 binding is not installed on the workstation, or it is not 
installed in the expected location. 

The file "/etc/gre.conf" contains information on the Mozilla version and the variable "GRE_PATH" 
whose value should point to the directory location where the appropriate Mozilla version has been 
installed.  In a default RedHat installation, this file contains the following information: 

[1.7.12]
GRE_PATH=/usr/lib/mozilla-1.7.12 

Workaround 
To fix this error do the following: 

1.	 Download Mozilla 1.7 for RedHat from the following FTP URL to a temporary directory: 

http://releases.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.12/contrib/mozilla-i686-pc-linux 
-gnu-1.7.12-gtk2+xft.tar.gz 

2.	 Uninstall any previous versions of Mozilla 

3.	 Extract the contents of this file to the /usr/lib/mozilla-1.7.12 directory as the root user 

4.	 Create or update "/etc/gre.d/gre.conf" to have the first two lines as below: 

[1.7.12]
GRE_PATH=/usr/lib/mozilla-1.7.12


5.	 Reinstall the Workplace Managed Client platform 

Alternatively, install Mozilla RPM manually: 

1.	 Download (or copy from RH4U3 Installation Disk 3) Mozilla RPM file (

mozilla-1.7.12-1.4.2.i386.rpm)


2.	 Right click the Mozilla RPM file in a file browser; in the context menu, select the "Open with 'Install 
Packages'" item 

3.	 Provide the root password to install packages 

4.	 After RPM installation, reinstall the Workplace Managed Client platform 

Upgrade notes 

Connecting to a Workplace Server 
A menu option is provided to connect to a Workplace Provisioning server. This option can be used to 
upgrade this standalone configuration, to provide access to all Workplace applications.  For details on 
how to use the Workplace Provisioning server, please refer to the Workplace Managed Client Help 
documentation. 
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Using the "Check for Updates" menu option 
A "Check for updates" menu item has been added that enables the Notes for Linux installation, from a 
CD-ROM or from a file system server, to search for updates.  For clients installed from a CD, selecting 
this action will look for updates on a CD or fileserver.  The location from which to obtain updates matches 
the location from which the client was first provisioned.  For example, the location from which CD-installed 
updates are obtained is typically the updateSite directory on the CD. 

Uninstallation information 

Uninstalling Notes for Linux 
Login as either the user who installed the software or root. 

In order to uninstall the products, there are uninstallers provided. 

To uninstall Notes 
Locate the directory where Notes has been installed and the sub-directory _uninst. 

# cd ~/notes/_uninst 
# ./uninstaller.bin 

To uninstall the WMC components 
Locate the directory where WMC has been installed and the sub-directory _uninst. 

# cd <WMC install directory>/_uninst 
# ./uninstaller.bin 

In both cases, dialogs appear in which you can continue clicking 'Next' until the uninstallation is finished. 
There is a choice of whether to remove user data as part of the uninstall. 
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Known limitations, problems, and workarounds 

Limitations 

Feature limitations of Notes for Linux

Following are the limitations of IBM Lotus Notes for Linux:


1.	 Integrated Instant Messaging is not provided with this release. 

2.	 Java Applets are not supported on Linux, however Java agents are available. 

3.	 There are no toolbars provided with Lotus Notes for Linux, however all options are available 
through the menu system. 

4.	 It is not possible to configure the Default page when using Notes for Linux. 

5.	 The Startup folder bookmarks are available, but not enabled. 

6.	 Object creation is not supported on Linux, because Linux does not support OLE technology. 

7.	 Lotus Notes Access for SAP solutions – This feature is only available on Microsoft Windows. 

Attachment viewing limitations

Following are the known limitations using and viewing attachments:


z	 Viewer for .sxi, .sxw, and .sxc files may not be presented correctly 
Sometimes, files with the above extensions can not be viewed, or may be presented incorrectly, for 
example, without pictures, tables, charts, etc.  Open Office document viewing will display text only -- 
this is currently a software limitation of our viewers. 

z	 Problem opening an attachment with an application which is not in the default application list 
If the default application list does not contain the application desired, it will not be listed when the 
attachment is right clicked and Open With is selected. 

z	 Creating an attachment triggers a warning dialog when the filename box is blank 

If you leave the filename box blank when creating an attachment (File -> Attach), a warning dialog 
saying the "function is inappropriate for file system directories" will appear.  Workaround by clicking 
OK and then re-attempting to attach a file, this time specifying a filename. 

z	 Editing an XLS attachment with graphics , then subsequently viewing it causes a crash 

Viewing or importing an attachment with a .xls file extension with graphics, which has been modified 
by OpenOffice, may cause a crash 
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Behavior of the window manager differs from Windows to Linux 
The behavior of the window manager is different on Notes for Linux, versus Notes on Windows, in the 
case where a user tries to activate the owner window of a modal dialog.  On Linux, the owner window will 
be activated (the title bar will be highlighted), while on Windows it is not active and the title bar remains 
gray. The importance of this relates to keyboard input, as no keyboard input is accepted in Notes until the 
dialog is activated. 

For other GNOME applications, for example gedit, when the owner window is highlighted, the keyboard 
input will be re-directed to the modal dialog, although the modal dialog shows a gray title bar then.  
Another possible difference is, by default on Windows, double-clicking on the title bar will maximize or 
restore the window, but on Linux this will roll-up or restore the window. 

Cancel during Notes installation may cause crash 
Cancelling during the initial installation of Notes may cause a crash when exiting from Workplace.  This 
will also cause NSD to run. 

Cannot Undo text color 
The text formatting option "Change text color" cannot be reversed using the 'Undo' option; the text 
remains selected. 

Color print and paper source selection has limitations 
You cannot select paper sources, and color printing is not supported. 

Creating image resources from a  .PNG file is not supported 
In the Notes Linux client, the item 'Create/Image Resource' opens a dialog for creating an image 
resource.  Clicking the "New" button in the resulting dialog opens a dialog listing all acceptable graphic 
files on the system that could be used to create an image resource.  .PNG files are not listed in this dialog, 
and are not supported as sources for creating new image resources. 

Designer Client and Admin Client not supported on Linux 
The Notes Designer Client and the Notes Administrator Client are not supported on Linux in either the 
provisioned or the CD installations.  These clients must be used on a Win32 machine instead. 
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Drag-and-drop has limitations

There are several known limitations with the drag-and-drop capability, as detailed below:


z	 Drag-and-drop a Notes document from Notes to a Linux folder or desktop  - In Windows, this 
results in a shortcut link being placed in the folder.  This feature relies on OLE, a 
Windows-specific protocol and will not be available for Notes for Linux. 

z	 Drag-and-drop via right-click of the mouse - Dragging/Dropping using the right mouse button is 
not supported in Notes for Linux.  Please use the left mouse button. 

z	 Drag-and-drop an attachment to an unopened OS folder  - Try to point to the folder which is 
currently open, not the folder under the drag cursor. 

z	 Drag-and-drop in progress grabs the keyboard  - When on Windows, ALT+TAB will switch to 
another application but on "X" nothing happens.  This is inconvenient if a user wants to bring up 
another window, but this is the same behavior as other GNOME applications, such as gedit. 

Import limitations and problems

Following are the issues associated with file importing:


z	 Cannot import .swc, .swx, .swi files to rich text fields 
Importing a file with an extension type of .swc, .swx, or .swi to a rich text field does not work.  
Although the dialog appears and you can click the button to create a file import, importing the file does 
not function. 

z	 When file type is Lotus PIC , don't select another type 
When importing a file to a document, if the File Type is Lotus PIC, but you select another type of filw ( 
abc.txt or abc.jpg), you will get an error: 

z Importing data into a view 
Data may still be imported into a view when cancelling the import operation. 
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International support issues 
Following are the international support issues: 

User interface 

z	 Unnecessary scroll bars appear in Preferences :  For Japanese mail template users, opening 
Calendar, and choosing "Actions -> Tools -> Preferences" or "Tools -> Preferences" from the 
Action menu button, will display 2 unnecessary scroll bars in the Preferences window. 

z	 String truncation in "Customize View":  For German language versions, there is a truncated string 
in the "Customize View" dialog. 

z	 File type with Simplified Chinese string will display incorrectly after selected a file in a list : For 
Simplified Chinese language versions, opening a database document, clicking "View -> Image 
Resource", and choosing the "New" button, brings up a drop-down list for "File Type"; Simplified 
Chinese strings will display incorrectly after selecting a file in this list. 

z	 GB18030-encoded file in a document will display incorrectly when viewed with locale setting 
zh_CN.UTF8:  If you attach a GB18030-encoded file in a document, it will display incorrectly 
when you view the file in Note, in the zh_CN.UTF8 locale; if the file is UTF-8 encoded, there is no 
problem. 

z	 Truncated button during installation .:The button "English" in the license agreement is truncated 
during installation to a German locale. 

z	 Menu items display issue :  Menu items ("About IBM Workplace", "Update . . .", "Connect to 
Server") will still display in English if a user has installed IBM Lotus Notes Client for Linux to the 
en_US locale, then switched to other locales.  If a user installs to another language locale, there 
is no such issue. 

z	 Text Properties issues :  Bold type will not take effect for Simplified Chinese characters. 

Accelerator key support issue 

Language Read mode Edit mode 
Brazilian Portuguese Ctrl+E could not switch 

document into Edit mode. 
Ctrl+E will call "Text 
Properties" though this is not 
expected.  It should switch 
document into Read mode. 

French Ctrl+e and Ctrl+E could not 
switch document into Edit 
mode. 

Ctrl+E could not save 
document. 

German Ctrl+E could not call 
"Find/Replace". 

Ctrl+E could not call 
"Find/Replace". 

Simplified Chinese Ctrl+E will call "Find/Replace" 
though this is not expected.  It 
should switch document into 
Edit mode. 

Ctrl+E will call "Find/Replace" 
though this is not expected.  It 
should switch document into 
Read mode. 
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Input Method support issues 

z	 Simplified Chinese IME support issue in  "New Database" dialog:  In the "New Database" dialog, 
a user needs to press Ctrl+Space to switch the IME each time the user inputs one Simplified 
Chinese character. 

z	 Traditional Chinese and Japanese IME icon does not display when user presses Ctrl +Space in 
dialogs:  In Traditional Chinese or Japanese locales, pressing Ctrl+Space does switch the input 
method and it will display the IME icon indicating what IME you are using, though the IME icon 
does not display when the user want to switch the IME in dialogs.  The user can still input 
language characters in the dialog. 

Full-Text Index support issue 

z	 In a UTF-8 locale, using a local database with a file name containing language characters, the 
full-text index could not be created.  If it is not in UTF-8 locale, index could be created. 

Java applets not supported

Inserting, importing, or displaying Java applets in rich text fields is not supported in this release.


Notes may corrupt memory while starting up 
If you run Notes with "MALLOC_CHECK_=2" set in the environment, it will not start. On RHEL 4 you get a 
crash dialog; on SLED 10, it just hangs. 

Operating system dialogs 
The Notes product uses operating system common dialogs, for example the "Open/Save File dialog", the 
"message box", and so on.  These dialogs have consistent native appearance as the system, but may 
have different appearance than other Notes dialogs. 

SLED 10 - Attachment limitations

Following are the limitations using attachments with SLED 10:


z	 Cannot use Edit/Edit With for an attachment 

z	 Cannot use Open/Open With for an attachment 

z	 If viewing attachments several times in a row, the "view" function will not work. 

SLED 10 - Drop-down selector cannot be expanded 
The drop-down selector on picture or document properties works only once; it cannot be expanded again 
after clicking the first time. 
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SLED 10 - Instant Messaging-related limitations

Following are the issues associated with Instant Messaging using SLED 10:


z	 No access to the Instant Messaging client 

z	 "Chat with team member" does not work - Working in the TeamRoom template, and clicking on the 
"Chat with Teammember" button causes a "Cannot execute the specified command" error to display. 

z	 Cannot chat with subteam  - When initiating a chat with a subteam, the command appears to start 
successfully, but never completes. No error dialog is shown, despite no chat window appearing. 

SLED 10 - Pop-up hotspot text in database positions poorly

Pop-up text always opens directly under the cursor icon; this makes part of the text unreadable.


SLED 10 - Section name displays incompletely

If you create a Section using SLED 10, the section title incorrectly displays as below:


SLED 10 - Slider does not scroll date in Calendar view

Dragging the slider on the Vertical/Horizontal scroll bar does not change the date in the Calendar view.


SLED 10 - Typeahead dialog fails on non-existent name

When the typeahead dialog of the "To:" mail field does not find a match, it indicates "non-existent name", 

but does not invoke a "No Match" ambiguous name dialog, as expected.


The client must be restarted when adding new printers

Adding or changing the printers available to Notes for Linux requires restarting Notes before the printers

will be recognized by those programs.
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The font "ZYSong18030" and "Luxi Sans" are required for RHEL4 
The following fonts are required when using RedHat Enterprise Linux 4: 

z	 For CJK locales, the font 'ZYSong18030' is used as the system default font.  If users do not install 
this font, provided by the RedHat Enterprise Linux 4 installation package, certain text layouts may 
be problematic.  The detailed font information is below: 

FileName: zysong.ttf

Font Name: ZYSong18030

Version: 2.01

Copyright: (c) Copyright ZhongYi Electronic Co., 2001


z	 To achieve a stable display result, we recommend that all Notes users pre-install the 'Luxi Sans' 
font. Note that the 'Luxi Sans' font is generally available on almost all Linux platforms, and will 
usually be installed during Linux system installation. 

Windows may become blurred after being overlaid by other windows 
This issue known to happen if OpenOffice application windows open on top of Notes dialogs, and may 
happen in other areas as well.  If a window display becomes corrupted after opening another window on 
top of it, the workaround is to close and reopen the dialog, or minimize and then redisplay the window to 
force it to repaint. 

X clipboard has some system limitations 
When a piece of data is copied into the clipboard on Windows, the source window can be closed, but the 
data is still stored in the clipboard.  On Linux, however, the source window should be present until the 
data is pasted to another window, otherwise nothing is transferred. 

Additionally, the X clipboard is not as reliable as the Windows clipboard, for example, "Copy/Paste" is 
slow on X Clipboard, because data is transferred between the X server and the source/destination clients 
piece by piece. 

"Open in New Window" does not open database 
Selecting a database and opening it by using the right-mouse-click option "Open in New Window" will not 
work.  please use your bookmarks, or the File -> Database -> Open menu item to open databases. 
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Known problems and workarounds


256-color display not fully supported 
Following are the known issues using a 256-color display: 

z Extra lines appear in dialogs 

z Dialog title bar is missing in some dialog boxes 

z Text and text selection are not displayed clearly 

z Workplace and other icons have opaque backgrounds 

A field in the User Security dialog displays incorrectly 
Open your Workspace and select a local database, choose File -> Security -> User Security; input 
password.  Next, select "Security Basics", click 'Compromised Password . . .', and then the 'Password 
Checking' button. You will see the following field displayed incorrectly: 

A Notes window flashes unexpectedly on the Welcome page 
When opening the Welcome page and clicking the triangle in the right side of the window, a Notes window 
may flash in the left of the welcome page. 
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Accelerator key changes for deselecting and deleting in a view
 In the Windows Notes client, pressing Alt+E+D deselects any selected files in a view.  However, when 
using Notes for Linux, pressing Alt+E+D+ENTER will delete any selected files in a view.  To deselect 
selected files while using Notes for Linux, press Alt+E+D, and then press D again, followed by ENTER. 

Agent related problems

Following are the issues related to using agents with Notes for Linux.  Until these issues are fixed, the 

workaround and recommendation is that users create any desired agents using a Windows client.


z	 Agent property dialog does not display when creating agent .  Open a mailbox, choose the menu 
option Create -> Agent,, and the Agent properties infobox displays, but then disappears immediately.  
This makes it very difficult to create an agent on the Linux system since, without access to the 
properties infobox, one cannot name the agent nor set when the agent is called. 

z	 Java agents are unable to create message box  - No message boxes are available using Java 
agents. 

Alarm dialog will not pop up when Notes is minimized

The Alarm notification dialog will not be displayed when Notes is minimized.


An unexpected broken line remains after removing mail folder

In a mail database, if you perform the following actions:


z	 From the menu choose Actions -> Folder -> Discover Folder 

z	 Click the "Add to Folder" button, choose 'Inbox', and click the "Add" button 

z	 Position the cursor on the Inbox item and Press 'Alt+R' 

the folder is removed successfully, but an unexpected broken line remains. 

Archive name changes may cause the archive to be lost

If an existing archive is renamed in the "archive setting" dialog box using the Edit button, followed by

<OK> to confirm, but then cancelling out of the "archive setting " dialog, the re-named archive will be

removed from the list of available archives.


Autosaved documents do not always display 
If the Managed Client crashes while you are working on an autosave-enabled document, you will be 
prompted to recover the document when the Client is restarted.  Even though the document does not 
display when you click on it and select Recover, it is there in the autosave database.  You can check this 
by opening the autosave database. 
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Broken display of drop shadow if width value is more than  60 
When the width of a Drop shadow for paragraph borders is set to more than 60, the drop shadow does not 
display properly. To workaround this issue, use a smaller width for the drop shadow. 

Button borders are not always displayed

For some button styles used within an outline, the button border will not be displayed.


Buttons in the same dialog have different styles

Click the "Address" button in the action bar; the buttons in the 'Select Address' dialog box are

inconsistent.  Some buttons have a solid black border, and some use a three-dimensional effect.


Calendar related problems

Following are the issues associated with the Calendar in Notes for Linux:


z	 Calendar control does not work well when rescheduling 
Drag an existing appointment to another date, and the Reschedule Options dialog pops up.  Clicking 
the date in the Calendar control, you will find that the Calendar control will not hide after you select a 
date; only when you click another empty space in the dialog will the Calendar control hide, and then 
the date will be adjusted. 

z	 Extra buttons display when switching  "All calendar Entries " 
When clicking the Calendar to open it., and switching tabs within Day, Week, Month and All Calendar 
entries, an extra row of tabs momentarily appears in the UI before the correct view displays. 

z	 There are two unexpected arrows when using an embedded calendar display . 
When using an embedded calendar display control, an additional down arrow maybe displayed on the 
bottom right corner of the calendar. This is cosmetic and does not affect the use of the calendar. 

Can't look through all lines when listbox height is small

When the listbox field height is small, the user can not scroll through all the items using the mouse wheel.  

Please use arrow keys in this instance.


Cannot Undo if changing text property by right clicking

The Undo option is not available if you modify a text property by right-clicking to open the text property

infobox.
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Characters are clipped incorrectly if more than  300 in a line 
If "No Wrap" is selected for paragraph alignment, the rich text field clips characters incorrectly when there 
are more than 300 characters on a line. 

Context menu 'Paste' is enabled rather than disabled by default 
The "Paste" menu item is enabled rather than disabled by default, implying that something is available for 
pasting when nothing may actually be available to paste.  Attempting to paste when nothing is stored on 
the clipboard results in a message window indicating that nothing is available on the clipboard. 

Copy/paste related problems

Following are the issues using copy/paste:


z	 Long text strings can not be copied and pasted from a web page or PowerPoint file to Notes rich 
text.  A message box "Unable to get data from clipboard" pops up.  Click "OK" to confirm this 
message box and try "Ctrl+V" again (you may need to repeat this several times); the text should be 
pasted successfuly. 

z	 Notes can not render  .bmp files in documents copied from OpenOffice .  If copying a document which 
includes .bmp files from an OpenOffice source into a Notes memo, the .bmp files will be missing. 

z	 No X-style copy/paste behavior. Copy-on-select and paste-on-middleclick, are not working in Notes 

z	 Pasting Chinese characters from Notes to OpenOffice Writer is broken . Chinese characters will not 
even display correctly in Notes after pasting into OpenOffice Writer. 

z	 Font changes via 'Paste special'.  Copying rich text and using the 'Paste special' option to paste the 
rich text into Notes changes the font from Default Sans Serif to Helvetica.  Workaround is to use 
'Paste' instead of 'Paste special'. 

z	 Copy/paste special text with Circle /Square/Checkmark list, the list property changes . The text copied 
may be pasted with different symbols from the original document. 

Creating Link and/or Phone Message takes time

Opening the Inbox, selecting a memo, and then choosing Create -> Special -> Link Message (or Phone 

Message) from the main menu, results in a lengthy wait before the "Link Message" and/or "Phone 

Message" is created.


CTRL+F6 does not work to switch between open windows 
CTRL+F6 should be available to switch between open windows, for example between the application and 
Help, but it has no response. 
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Cursor disappears pressing Left or Right key on  "Open DB" dialog 
The cursor disappears when pressing either the  <left> or <right> key in the combo box of the "Open 
Database" dialog box.  To see this error, press <Ctrl+O> to open the "Open Database" dialog box (focus 
in the combo box to select a server),press <left> or <right> key, and the cursor will disappear. 

Workaround:  Use the mouse to point to a field and click -- the cursor will reappear or close and reopen 
the Open Database dialog. 

Dragging a bookmark should not open it 
In the Notes Application, dragging any bookmark (for example Mail, Calendar, To Do, Address Book and 
so on) to adjust its order, opens the database, when it should not. 

Dragging an attachment may select other attachments 
If there are many attachments in a document, selecting one of them (although, not the last one) and 
dragging the selected attachment, may cause some of the other attachments to be selected also. 

Embedded view action bar displays incorrectly 
Clicking on the "Embedded View" icon can select a view with an action bar, but the bar displays 
incorrectly, as shown below: 
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Error message in countered "To Do"

There is an error message using the countered "To Do" entry, as in the following scenario:


1.	 An Assigner sends a group To Do to an Assignee 

2.	 The Assignee selects "Respond with Comments" -> "Propose New Date", inputs new date, and clicks 
OK 

3.	 Attach an attachment to the To Do, and send it back to the Assigner 

4.	 When the Assigner opens this countered To Do, they see the error shown in the Description below 

Note: Assignee "Accept with comments" and "Decline with comments" also have this problem. 

Export related issues

Following are the issues associated with exporting files:


z	 Choosing File -> Export, and not inputting a file name before clicking the "Export" button, brings up a 
dialog with the button "Replace".  Choosing this button causes the following error message to display: 

z Notes hangs when exporting an open contact document as vCard2.1 or vCard3.0 
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z	 Exporting a .GIF picture to a Rich Text file, then importing the RTF files, changes the .GIF picture 
properties 

z	 After an Export is cancelled, the status bar message still displays it was successful: 

File -> Exit in a mail database may display error message 
In a mail database, closing the Inbox tab and then quickly choosing File -> Exit from the menu, may 
display the error message "An error has occurred when closing the workbench. See error log for more details." 
displays. This error can be ignored. 

If install path includes "#" Notes can not be uninstalled 
The uninstaller is unable to uninstall Notes if the installation path includes the "#" character. 

In some teamrooms, some underlines display as broken lines 
Some teamroom displays, such as lists of names, may display the underlining as a dotted or broken line. 

Incorrect cursor and unexpected lines after importing a graph 
When importing graphics into a Rich Text field, and right-clicking to select "Add Hotspot Rectangle", "Add 
Hotspot Circle", or "Add Hotspot Polygon", the cursor displays incorrectly, along with a few erroneous 
cosmetic lines on the dialog. 
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Japanese locale issues 
Following are the issues using the Japanese locale setting: 

z	 Down arrow is covered by the tab title in Japanese calendar . If the locale is ja_JP.UTF-8, the tab 
down arrow of the Calendar view is covered with the string "All Calendar Entries", as shown 
below: 

Java debugging does not work well

Java debugging does not work and may, in some cases, cause Notes to hang.


Low resolution (800x600) can make menus inaccessible

If the screen display is set for a low resolution (800x600 or 640x480), menus with multiple right-click 

menus may display the right-click menus off the screen, and the mouse can not navigate to them.  

Instead, use the keyboard to navigate.


Menu loss when switching between virtual desktops

When switching from the virtual desktop to Notes, the full menus will not be displayed.  To re-enable, 

select one of the open tabs within the window, or open a new one.


Menu UI problems

Following are the issues associated with the Menu UI:


z	 File menu items are not grouped or separated by separator 
Expand the File menu; you will notice menu items are not grouped or separated by a separator in a 
reasonable way. 

z	 Menu 'Chat' is useless 
Chat menu item is disabled and useless as Chat is not supported in current version. 
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z	 File->close does not work and the width is too small 
See the example in the screen shot below: 

No first letter index in New Database dialog 
In the New Database dialog box, there is no first letter index in the template list.  In addition, for the 
Calendar "Tools\Import Holidays"operation, no first letter index appears in the Holidays list. 

No focus on confirmation dialog box to delete a database 
Focus on the "Delete Database" message is lost if the cursor moves over the Workplace window. Focus 
on the Yes/No buttons can be regained by clicking on the message with the mouse. 

Notes crashes if clicking blank area before sub -directory shows 
Clicking "Favorite Bookmarks" or "Databases" on the bookmark pane in the left of the Notes interface, and 
then clicking the blank area quickly before the sub-directory titles are displayed, crashes Notes. 

Notes does not know server availability during configuration 
Notes does not recognize changes in server availability if there is no network connection before Notes 
starts, and is reconnected while using the configuration wizard. 
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Notes hangs if dragging an attachment a few times 
Selecting an attachment in a document, and dragging it through the border of the Notes client a few times 
will hang the application. 

Notes may crash if scheduling a meeting 
Notes will crash if you schedule a meeting by doing the following: 

1. Launch Notes 

2. Create a meeting 

3. Click on the button next to the 'Required to' field 

4. Click '?' on the 'Select Addresses' dialog (do not close the following Help dialog) 

5. Click on the 'Details' button on the 'Select Addresses' dialog 

6. Click the 'Cancel' button to quit the 'Select Addresses' dialog 

7. Click the 'Close' button to close the 'Address details' dialog; Notes will crash 

Notes tooltips pop-up even when Workplace client is minimized

In some circumstances, when the Workplace client is minimized with an active tooltip, the tooltip may still

be displayed.


OLE is not supported on Linux

The menu option "Create -> Object" is disabled in Edit mode, as OLE is not supported on Linux.


Operations may be slower than on Windows

The overall client operations maybe be slower for Linux on Notes in some cases than on Windows, 

particularly around startup and some network activities.
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Page break character does not display correctly 
Page break characters display incorrectly, as shown in the example below: 

Pressing "ESC" or "Enter" in expanded combobox closes the dialog 
To schedule a repeating meeting, in the "Repeat Options" dialog box, expand a combobox list and press 
the ESC or Enter key, the "Repeat Options" dialog box closes, when it should only minimize the 
combobox list. 

Problems restarting Notes after an error 
In some circumstances, it may not be possible to successfully restart Notes after a previous error. 

Workaround 
The nsd.sh script will ensure that any remaining processes have been terminated.  The script maybe 
used as follows: 

#cd $NOTESDATA

#$NOTESBIN/nsd.sh -kill


The Notes client can then be successfully restarted from the desktop. 

Problems with focus handling 
Notes for Linux has some problems on focus handling, which may result in controls not always having 
focus as they should. The user may have to click the controls manually to ensure they have focus.  For 
example there are known issues with: 

z Focus in Agent properties infobox 

z In the Replication setting dialog box, the user cannot move focus to  and buttons with the 
keyboard. 
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Repainting occurs frequently 
Notes for Linux will repaint the screen more often than seen on Windows installations. 

Scrolling is slow when viewing large embedded view page 
When viewing a large embedded view, if you hold the scrolling widget and use the mouse to move 
up/down very quickly, the scrolling speed becomes very slow. 

Search option: No right parentheses for checkbox 
In the Search option dialog "Use word variants ('cat' will also find 'cats')", note that the closing parenthesis 
is missing: 

Send Document dialog missing the words  "Mailing Options"

When selecting the menu option "Actions -> Send Document", the Send Document dialog is missing the

words "Mailing Options" from the display, as shown below:


Incorrect 

Correct 
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Setting Replication page as home page not supported 
In Notes for Linux you cannot set the home page to be anything other than the Welcome page.  If you set 
the home page in a Windows installation to something else, and then copy bookmark.nsf from the 
Windows system to the Linux system, the home page will be respected by the Linux system, EXCEPT if 
the home page is set to the Replication page.  The Linux Plugin will not accept the Replication page as 
the home page. 

Shortcut keys do not work in Create view dialog box .

Clicking the menu option Create -> View in a mail database, the shortcut keys (Alt+A, Alt+F, etc.) will not

work.


SLED 10 - XGL-specific issues

Following are the issues related to XGL on SLED 10:


z	 Switching to different desktops using CTRL+ALT+<arrow key> leaves artifacts - CTRL+ALT causes 
numbers on the action button to appear in the mail inbox (or other view with action buttons), while 
releasing CTRL+ALT makes the numbers disappear, but using CTRL+ALT+<arrow key> to switch to 
another desktop and then switch back leaves those numbers. 

z	 ALT+<shortcut key> fails to activate main menu - When a view with an action button opens, pressing 
ALT+<shortcut key> fails to activate the drop-down menu. 

z	 Welcome page does not come up when rotating desktop - The Calendar page and other pages, like 
the Welcome screen, cannot be seen when the desktop (workspace) is rotated using 
CTRL+ALT+<arrow key>. 

z	 Log-in dialog box is not centered within Lotus Notes - This is an intermittent issue, which may be seen 
on non-1024x768 resolution screens. 

z	 If you hover the mouse over a Calendar entry, the pop-up tip flashes momentarily, as does the main 
menu bar. 

Smartcard is not supported for Notes for Linux

The Smartcard capability is not supported for Notes for Linux.


Some fonts used in graphs do not display well

Graphs that have been copied and pasted from Windows applications may contain fonts that will not be

rendered correctly in Notes for Linux. Letters may appear to be too close and/or truncated.


Some property dialogs have extra blank space 
Some property dialog boxes, for example 'Section' or 'Embedded View', may include extra blank space at 
the bottom of the dialog. 
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Teamroom Navigator pane may display incorrectly

This issue occurs in the following scenario:


z	 Create a new Teamroom database; the "About this database" document will open. 

z	 Choose "Set Up TeamRoom Now", then click 'Cancel'. 

z	 Choose File -> Database -> Properties, and the 'Launch' Tab; select 'Open "About this database" 
document'. 

z	 When opened in the Notes client list, close the database infobox. 

z	 Close the database and reopen it; the "About . . ." document will open. 

z	 Close the "About . . ." document; the Teamroom displays incorrectly as shown below: 

The Save dialog appears unexpectedly in a meeting notice 
The Save dialog box appears while clicking the "Open meeting" button, after double-clicking in the 
Meeting Notice window. 

TimeZone field loses focus after selecting a time zone 
For the TimeZone field, selecting a time zone by left-clicking the mouse, causes the TimeZone field to 
lose focus. 

Two F1 accelerators are presented together under help menu 
Under the Help menu, two sub-menu items - Context Help and Help Contents - have the same F1 
accelerator listed. 
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Two File menus may be presented at the same time 
In some cases, two file menus may be presented at the same time, for example, clicking the Notes menu 
bar when the Context Help window is opening in front of Notes. 

UI element repaint limitations 
Following are issues associated with re-painting in the UI: 

z	 Two combo boxes, "Search in view bar" and "To do item" do not refresh correctly 

z	 For a To Do entry, changing the item value of the "Priority" combo box, and then changing the 
focus, does not correctly refresh that combo box. 

z	 In a mail database, a portion of the 'Subject' column title bar does not repaint while dragging it. 

z	 In a mail database, a portion of the "Agent" action window does not repaint correctly while

dragging it.


z	 Buttons on a Notes dialog box do not refresh correctly when a window on top of it is minimized. 

z	 Truncation and alignment issues display on the Mail Preferences page for Followup actions. 

Unexpected scroll bar in Proxy Server Configuration dialog 

Choosing "File -> Mobile -> Edit Current Location" from the menu, and clicking the  icon opens the 
'Proxy Server Configuration' dialog box - an unexpected scroll bar displays. 

URL links dropped into a document cannot open browser 
If a URL link on the desktop is dragged-and-dropped into a document in Notes, clicking it will not cause 
the system browser to open the link. The user will need to start the browser manually, and then 
copy/paste the URL into the browser to follow the link. 

User defined color can not be added to custom colors 
On Linux, the color picker is different than on the Windows32 platform.  Custom colors can be defined for 
use, for example, setting text color, but they cannot be saved as Notes custom colors. 

User Security - "Select Slot" button causes crash 
Choose File -> Security -> User security, input your password, and select Your Identity -> Your 
Smartcard; a dialog box appears. Close this dialog box, and choose "Configuration Details"; if you then 
click the "Select Slot" button in the Smartcard configuration details dialog box, red error message box 
appears and the application crashes. 
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Using ESC to cancel from internal browser window does not work 
Opening a web page from the Notes internal browser, and then using the ESC key to cancel from the 
internal browser window does not work. 

Using <F5> to lock Notes does not hide open Notes dialog 
Pressing <F5> locks the Notes client, but open dialog boxes may still appear on screen, when they should 
be hidden. 

Vertical lines maybe displayed when cancelling a selection 
When selecting text that includes Notes sections, when clearing the selection, vertical lines may be left 
behind. This is cosmetic, and will be cleared on the next screen paint. 

Vertical mouse hotspot may be inaccurate 
In some situations the mouse hotspot may not correspond vertically with it's current location, and may be 
lower than the intended target.  It is recommended to close and restart the application should this occur. 

View Calendar -> Day does not display To Do entries 
If you uncheck the "Do not display To Do entries in the Calendar" option, create a To Do entry, and do not 
input a "Start by" parameter, then save, close, and switch the Calendar view to "Day", you will not see the 
To Do that you created. 

Visible half-toning in printouts on a 1200dpi printer 
Printing documents using either Default Monospace or Default Sans Serif fonts yields printouts with 
visible half-toning on the edges of each character. 

When minimizing Notes, the color option dialog may remain 
If the color option dialog is left open when Notes is minimized, the color "picker" will remain on screen.  It 
may be removed by restoring Notes, and closing the color picker. 
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Zoom in/out preview page causes hand cursor appearance

Opening a document, then choosing File -> Print Preview, you will notice that if you zoom in to the page, 

the cursor changes to an arrow, while if you zoom out, the cursor changes to a hand.


"Choose a View based on a formula " checkbox is not gray 
Open a database with a Rich Text Lite field, with an "Embedded View" option set, clicking the "Embedded 
View" icon allows you to select a view, but the "Choose a View based on a formula" checkbox should be 
gray, instead of highlighted. 

<Enter> and <ESC> don't work on some expanded combo boxes 
Some expanded combo boxes in Rich Text or Notes dialog boxes can not confirm a selected item by 
using the <Enter> key, and can not be collapsed by using the <Esc> key. 

<F1> opens Help window but menu remains on screen 
When the main menu displays, pressing <F1> opens the Help window, but the menu still appears on 
screen. 
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Notices and Trademarks 

Notices 
This information was developed for products and services offered in the USA. IBM may not offer the 
products, services, or features discussed in this document in all countries. Consult your local IBM 
representative for information on the products and services currently available in your area. Any reference 
to an IBM product, program, or service is not intended to state or imply that only that IBM product, 
program, or service may be used. Any functionally equivalent product, program, or service that does not 
infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to 
evaluate and verify the operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter described in this document. 
The furnishing of this document does not give you any license to these patents. You can send license 
inquiries, in writing, to: 

IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A. 

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property 
Department in your country/region or send inquiries, in writing, to: 

IBM World Trade Asia Corporation Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106, Japan 

The following paragraph does not apply to the United Kingdom or any other country/region where such 
provisions are inconsistent with local law: 

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" 
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, OR 
FITNESS FOR A PARTICULAR PURPOSE. 

Some states do not allow disclaimer of express or implied warranties in certain transactions; therefore, 
this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein; these changes will be incorporated in new editions of the publication. IBM 
may make improvements and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience only and do not in 
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part 
of the materials for this IBM product, and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you. 
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Licensees of this program who wish to have information about it for the purpose of enabling: (i) the 
exchange of information between independently created programs and other programs (including this 
one) and (ii) the mutual use of the information that has been exchanged, should contact: 

Lotus Software 
IBM Software Group 
One Rogers Street 
Cambridge, MA 02142 
USA 

Such information may be available, subject to appropriate terms and conditions, including in some cases 
payment of a fee. 

The licensed program described in this document and all licensed material available for it are provided by 
IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement, or by 
any equivalent agreement between us. 

Any performance data contained herein was determined in a controlled environment. Therefore, the 
results obtained in other operating environments may vary significantly. Some measurements may have 
been made on development-level systems, and there is no guarantee that these measurements will be 
the same on generally available systems.  Furthermore, some measurements may have been estimated 
through extrapolation. Actual results may vary. Users of this document should verify the applicable data 
for their specific environment. 

Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements, or other publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility, or any other claims related to non-IBM 
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of 
those products. 

All statements regarding IBM's future direction or intent are subject to change or withdrawal without 
notice, and represent goals and objectives only. 

This information contains examples of data and reports used in daily business operations. To illustrate 
them as completely as possible, the examples include the names of individuals, companies, brands, and 
products.  All of these names are fictitious and any similarity to the names and addresses used by an 
actual business enterprise is entirely coincidental. 
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